在這裡提供Frame Relay NBMA 之 的設定,先看架構圖:


先針對中間那朵雲 Frame Relay Switching Cloud 的 IOS Startup-Config 做設定,需要的人可以COPY以下的 CLI 內容:
configure terminal
hostname FR_SW
no ip domain-lookup
enable password cisco
line con 0
exec-timeout 0 0
logging synchronous
history size 100
password cisco
login
exit
line vty 0 5
password cisco
login
exit

frame-relay switching
interface serial 0/0
no ip address
clock rate 64000
encapsulation frame-relay
frame-relay lmi-type ansi
frame-relay intf-type dce
frame-relay route 102 interface Serial0/1 201
frame-relay route 103 interface Serial0/2 301
frame-relay route 104 interface Serial0/3 401
frame-relay route 105 interface Serial1/0 501
no shutdown
exit
interface serial 0/1
clock rate 64000
encapsulation frame-relay
frame-relay intf-type dce
frame-relay lmi-type q933a
no ip address
frame-relay route 201 interface serial 0/0 102
no shutdown
exit
interface serial 0/2
clock rate 64000
encapsulation frame-relay
frame-relay intf-type dce
frame-relay lmi-type q933a
no ip address
frame-relay route 301 interface serial 0/0 103
no shutdown
exit
interface serial 0/3
clock rate 64000
encapsulation frame-relay
frame-relay intf-type dce
frame-relay lmi-type q933a
no ip address
frame-relay route 401 interface serial 0/0 104
no shutdown
exit
interface serial 1/0
clock rate 64000
encapsulation frame-relay
frame-relay intf-type dce
frame-relay lmi-type q933a
no ip address
frame-relay route 501 interface serial 0/0 105
no shutdown
end

接著是中間上面的Headquarters P1R1 Router做設定:
configure terminal
hostname P1R1
no ip domain-lookup
enable password cisco
line con 0
exec-timeout 0 0
logging synchronous
history size 100
password cisco
login
exit
line vty 0 5
password cisco
login
exit
interface serial 0/0
no ip split-horizon
no ip address
clock rate 64000
encapsulation frame-relay
frame-relay lmi-type ansi
frame-relay intf-type dte
no shutdown
exit
interface serial 0/0.1 multipoint
no ip split-horizon
ip address 10.1.1.1 255.255.255.0
bandwidth 64
frame-relay map ip 10.1.1.2 102 broadcast ietf nocompress
frame-relay map ip 10.1.1.3 103 broadcast ietf nocompress
frame-relay map ip 10.1.1.4 104 broadcast ietf nocompress
frame-relay map ip 10.1.1.5 105 broadcast ietf nocompress
no shutdown
exit
interface ethernet 1/0
ip address 192.168.1.17 255.255.255.240
no keepalive
no shutdown
exit
router rip
version 2
no auto-summary
network 192.168.1.0
network 10.0.0.0
end
接著是下面的BenchOffice P???R1 Router們做設定,因為設定差不多,我只貼出一台,其餘的請大家修改後使用:
configure terminal
hostname P5R1
no ip domain-lookup
enable password cisco
line con 0
exec-timeout 0 0
logging synchronous
history size 100
password cisco
login
exit
line vty 0 5
password cisco
login
exit
interface serial 0/0
no ip split-horizon
ip address 10.1.1.5 255.255.255.0
clock rate 64000
bandwidth 64
encapsulation frame-relay
frame-relay intf-type dte
frame-relay lmi-type q933a
frame-relay map ip 10.1.1.1 501 broadcast ietf nocompress
no shutdown
exit
interface ethernet 1/0
ip address 192.168.5.17 255.255.255.240
no keepalive
no shutdown
exit
router rip
version 2
no auto-summary
network 192.168.5.0
network 10.0.0.0
end
RIP over MultiPoint FrameRelay 的結果比較:
P1R1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

R    192.168.4.0/24 [120/1] via 10.1.1.4, 00:00:34, Serial0/0.1
R    192.168.5.0/24 [120/1] via 10.1.1.5, 00:00:26, Serial0/0.1
     10.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, Serial0/0.1
     192.168.1.0/28 is subnetted, 1 subnets
C       192.168.1.16 is directly connected, Ethernet1/0
R    192.168.2.0/24 [120/1] via 10.1.1.2, 00:00:22, Serial0/0.1
R    192.168.3.0/24 [120/1] via 10.1.1.3, 00:00:25, Serial0/0.1

##################################################
以下結果為每一顆Router 添加以下CLI指令
P1R1#router rip
version 2
no auto-summary
之IP Route變更後的結果
----------------------------------------------
Gateway of last resort is not set

     192.168.4.0/28 is subnetted, 1 subnets
R       192.168.4.16 [120/1] via 10.1.1.4, 00:00:17, Serial0/0.1
     192.168.5.0/28 is subnetted, 1 subnets
R       192.168.5.16 [120/1] via 10.1.1.5, 00:00:01, Serial0/0.1
     10.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, Serial0/0.1
     192.168.1.0/28 is subnetted, 1 subnets
C       192.168.1.16 is directly connected, Ethernet1/0
     192.168.2.0/28 is subnetted, 1 subnets
R       192.168.2.16 [120/1] via 10.1.1.2, 00:00:02, Serial0/0.1
     192.168.3.0/28 is subnetted, 1 subnets
R       192.168.3.16 [120/1] via 10.1.1.3, 00:00:11, Serial0/0.1

=================================================

P1R1#sh frame-relay map
Serial0/0.1 (up): ip 10.1.1.2 dlci 102(0x66,0x1860), static,
              broadcast,
              IETF, status defined, active
Serial0/0.1 (up): ip 10.1.1.3 dlci 103(0x67,0x1870), static,
              broadcast,
              IETF, status defined, active
Serial0/0.1 (up): ip 10.1.1.4 dlci 104(0x68,0x1880), static,
              broadcast,
              IETF, status defined, active
Serial0/0.1 (up): ip 10.1.1.5 dlci 105(0x69,0x1890), static,
              broadcast,
              IETF, status defined, active



HarlemHsu 發表在 痞客邦 PIXNET 留言(0) 人氣()