最近有收到一個網路擴頻的需求,我們不考慮在原先的線路上做直接升頻(擴頻)的申請,雖然這樣比較簡單,兩端點的網路設備也不需要做任何設定。為了達到路由路徑的的容錯,我們向 ISP申請另一路FTTB線路。下圖為施工前的部分網路圖:



施工完畢後的圖:

依據 cisco 的產品,equal cost routting 的話會自動到 Load share by packet 的功能。
但是這樣真的好嗎?不見得喔,使用單位希望達到以下的功能:
1.一般遠端控管、程式碼上傳、網站資料上傳等等,流量資料走舊的 2M FTTB頻寬。
2.資料庫同步與遠端備份的流量侷限在第二條新的線路上。
3.以上未定義的其他流量自動 load share頻寬。

首先我在IDC端的L3 Switch VLAN100介面上key了﹝ip policy route-map ROUTE_2_HQ﹞,發現這行指令是錯誤的,經過查驗我才知道這台L3 Switch IOS版本為3560G's with IP Base 12.2(25)SEE2,完全不支援IP Policy Route-Map策略性路由的指令啊!

既然不支援IP Policy,那只好硬著頭皮升級IOS版本了,升級的過程就不在此贅述。升級完畢後,IP Policy Route-Map 也可以下了,輕輕鬆鬆的key完 Access-List、Route-Map xxxxx,等等指令,以為這樣就完工了。

數天後,電話那頭大喊:「頻寬爆啦,所有的流量都亂導!」我趕緊到MRTG上查看流量,┘快暈倒~

反覆性的看Running Config,看不出啥錯的地方,索性 NO掉所有IP Policy重新再來一次,這次我眼尖看到一行Message:

DSNP(config-if)#ip policy route-map ORACLE_DB
DSNP(config-if)#exit
00:36:21: %PLATFORM_PBR-4-SDM_MISMATCH: PBR requires sdm template routingit

我直覺性的就認為問題在這裡,用Google與cisco官方網站詢找答案,再追加了一行指令【sdm prefer】& Reload Switch後,IP Policy就被套用了。確認一下~

DSNP#show sdm prefer

 The current template is "desktop routing" template.
 The selected template optimizes the resources in
 the switch to support this level of features for
 8 routed interfaces and 1024 VLANs.

  number of unicast mac addresses:                  3K
  number of IPv4 IGMP groups + multicast routes:    1K
  number of IPv4 unicast routes:                    11K
    number of directly-connected IPv4 hosts:        3K
    number of indirect IPv4 routes:                 8K
  number of IPv4 policy based routing aces:         512
  number of IPv4/MAC qos aces:                      512
  number of IPv4/MAC security aces:                 1K

注意:【sdm prefer】這指令是『隱藏型指令』,因為它跟Shutdown一樣,預設是不會SHOW出來的,所以我在其他台Switch上Show Runn一千次,我也看不到這行指令是否被執行過,好你個思科.......

CUT出部分CLI分享給大家參考一下,某些資料走的PORT Number比較敏感,我換成 IP給大家參考:

interface Vlan100
 ip address 7.19.0.254 255.255.0.0
 ip policy route-map ROUTE_TO_HQ101F

ip access-list extended 168_IDC_AP2_TO_HQ_VLAN9
 permit ip host 7.19.0.182 10.50.109.0 0.0.0.255
 permit ip host 7.19.0.82 host 2.17.4.76

ip access-list extended 168_DB_TO_HQ_VLAN10
 permit ip host 7.19.0.92 host 172.17.109.147

route-map ROUTE_TO_HQ101F permit 10
 description 記得寫一些註解,方便日後維運喔!比如:線路編號,連接端點等等~
 match ip address 168_IDC_AP2_TO_HQ_VLAN9
 set ip next-hop 100.10.170.1
!
route-map ROUTE_TO_HQ101F permit 20
 description 記得寫一些註解,方便日後維運喔!比如:線路編號,連接端點等等~
 match ip address 168_DB_TO_HQ_VLAN10
 set ip next-hop 100.10.170.5

延伸閱讀:
CISCO官網:Configuring SDM Templates
CISCO官網:Messages and Recovery Procedures






創作者介紹

HarlemHsu

HarlemHsu 發表在 痞客邦 PIXNET 留言(1) 人氣()


留言列表 (1)

發表留言
  • daniel
  • 請教一下<br />
    我加了PBR到我的3560後,Routing看起來好像正常 , 但是我卻telnet不到Router了,<br />
    請問有遇到這個情況嗎?<br />
    <br />
    <br />
    另外PBR的priority會高於direct Connect或static route嗎?,因為加了Route-<br />
    map後,同一台Router上的其他網段反而ping 不到了,好像被強制走route-map 指定的<br />
    next-hop去了,如果原本只有default route , 需要加什麼來配合 PBR 嗎?<br />
    <br />
    以下是我的相關設定 , 謝謝<br />
    <br />
    interface Vlan100<br />
    ip address 172.26.100.254 255.255.255.0<br />
    ip policy route-map RM-100<br />
    <br />
    ip access-list extended FOR-100<br />
    permit ip 172.26.100.0 0.0.0.255 any<br />
    <br />
    route-map RM-100 permit 10<br />
    match ip address FOR-100<br />
    set ip next-hop 172.26.100.253<br />
    <br />
    ip route 0.0.0.0 0.0.0.0 192.168.162.101
  • 不知道您的網路架構,但我猜是因為這一行的關係....
    permit ip 172.26.100.0 0.0.0.255 any
    只要是Source封包 IP Range:172.26.100.0/24的【所有流量】都會因PBR強制導向172.26.100.253。

    HarlemHsu 於 2008/07/28 08:43 回覆

找更多相關文章與討論